Home Forums OS X Server and Client Discussion Questions and Answers What does "an AppleShare system error occurred" mean in Panther?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #360546

    Hi. I have seen this “an AppleShare system error occurred” error on various of my clients, very sporadically. I get it when trying to connect to my Panther server through various mechanisms (Connect to Server, a scripted mount command, etc.).

    This error message appears sporadically in Google… In every instance, someone reports that they get this error, but *nobody* ever has any idea what it means. It even appears in this forum a couple times, but nobody ever has any opinions on it.

    AppleShare has nothing to do with this connection, as far as I know. I don’t have AppleTalk browsing turned on on my OSXS. I’m only using Panther machines on both sides.

    I’ve seen this on my local network, and when trying to connect remotely. The message appears as soon as I click Connect in the connect to server dialog.

    Does anyone know what this message means?


    [QUOTE BY= MacTroll] AppleShare is NOT AppleTalk.

    AppleShare is AFP.

    Tell us a more about your setup.[/QUOTE]
    Yeah… I was starting to suspect that.

    Of course I’m interested in solving whatever problem I may have in my setup… but I’m, almost more interested in figuring out what this message means. It is worthy of Microsoft, it is so uninformative.

    Anyway, my setup is Panther Server running DHCP, Open Directory Master, DNS, and AFP. Clients are all Managed/Mobile, authenticating via Kerberos. Almost all setup has been done via the OSXS GUI.

    Everything seems to run pretty smoothly, except every now and again a client will have some problems connecting or mounting. The latest instance I experienced was when I was outside the network, trying to Connect to Server from a standalone client (my own computer, not a company Managed/Mobile client). Even rebooting won’t fix that AppleShare message. My colleagues can connect via a similar setup with no problems. We also get this message in-house, very sporadically. We also see other mount problems, again sporadically.

    If the problem were consistant, I would suspect the config, but the fact that it appears to be very random makes me scratch my head and frown.

    If I could just get a handle on what this error is supposed to mean, at least I would have an idea of what to look at. As far as I can tell, it is not documented anywhere, and I can find nobody on the internet who has had anything to say about it.

    The one thing I can think of that I haven’t done is to try using the same client to connect to another AFP server, to at least see if the problem is in the client or the server. Is there any public AFP server that allows public logins for some reason?


    [QUOTE BY= MacTroll] Just for fun try turning off Kerberos Authentication for AFP in Server Admin. Change the auth method to just Standard. Then stop/start the AFP server.[/QUOTE]Hm. It’s a live server, so I’m a little leery of turning off Kerb.

    I just overcame a bout of retardedness and solved one part of this puzzle. I was always getting the AppleShare error when trying to connect remotely with my own laptop. Just today I had the brainstorm of trying to connect from another Mac from my home network, and it connected fine. So in this one instance, the problem is local to the client (I’ll try deleting a bunch of prefs on it and see if I can sledgehammer the problem away… though I’m open to suggestions, if someone can tell me how to reset whatever may be involved in producing an AppleShare system error).

    On my corporate network, we still get random strange errors. Rarely, we see this AppleShare message. Other times, people just can’t log in to the server for one reason or another. In almost every case, a reboot of the client fixes it. I now suspect the network infrastructure itself, suspecting that a critical packet is dropped or lost just at the time Kerb is kicking in. I think. Networking is not my strong point, so this is near-random guessing, but seems right. I’m about to being in an outside networking specialist. Unless any other suggestions are forthcoming…? Smile

    I still wish I knew what this error message was supposed to mean. I can’t even find any log entries (in any log) that match when I try to connect.


    Server and clients are on 10.3.7, with all updates.

    On the network, we have not been able to identify any particular hotspot of trouble activity. Behavior is more gremlinish. We’ve had very few reports of any connection problems in the past week, and reboots always fix it. That issue I think is due to an issue in network wiring.

    In my own case, the plot has thickened. I can connect to any other AFP server from my client machine, but not to my own. So it is NOT just a matter of misconfiguration of my client. I guess.

    I’ve cleared out all the system level caches and preferences without any effect. The appleshare system error happens immediately after I press the connect button on Connect to Server. I’m trying to find my PB CDs to reinstall the OS… my generic Panther install is too old for an AlBook.

    I’m very confused that another 10.3.7 client can connect to my server from my home network. And my PB can connect to any other AFP server.

    What could interfere with this particular connection and nothing else?

    Confused Confused Frown Eek! Confused Confused


    This AppleShare error occurs before I get the challenge window. As soon as I click “connect,” I get the error.

    As far as I can tell, the “secure connections” checkbox is part of the challenge dialog. I can’t turn that off without getting to it first… Smile Is it configurable elsewhere?

    P.S. Do I have to have port 427 open on my firewall? I see little documentation of it, and I doubt that’s the case as I can get in with other machines, but… thought I might as well ask.


    I have had this problem on my freshly configured setup – Mac OS X 10.3.9 client in AD, Mac OS X Server 10.4.7 in AD, Kerberised AFP service on the server, client is part of a Magic Triangle, Authentication on the server is via AD before /LDAPv3/

    You get this error before the login panel because Kerberos is stepping in first. Telling you to turn off Kerberos as an authentication method for AFP in Server Admin, means opening Server Admin, pointing it to your server, clicking AFP and using the Authentication pop-up in the settings … NOT a change on the client. When you do this, the normal AppleShare/AFP login panel occurs.

    It “fixed” my problem, so I no longer get this error and I can log in manually, but I would like to get Kerberised AFP going.

    I have a test server which is configured the same (as much/far as I can tell) as my regular server, and it successfully does Kerberised AFP without errors. My regular server was upgraded from Server 10.3.x where I was not running Kerberos, while the test server was installed clean. My client testing (to both servers) is from the same 10.3.9 client machine. Both servers are in the same AD domain.

    On both servers, I can do kinit username and auth okay.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Comments are closed