Home Forums Software InstaDMG USB errors in instaDMG

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #375627

    The image this pertained to was created using a MacBookPro (new unibody) from the retail disks that came with it.
    It was then applied to a MB, new unibody. After much testing it was decided to be stable…..
    silly me, I should have known better. So this turned out to be a minor but real issue and everyone should take it as one more reason to be careful with images built from machine specific install disks.

    The network engineer who got the machine in question could not get it to stay asleep. It would sleep, and then wake up 15 minutes later. While in his bag.
    He looked online and found lots of answers, none of which worked, and he concluded it was hardware.
    As a last ditch he tried a hunch of his and:

    [quote]I tracked the problem down to a mis-firing IOUSBFamily kernel
    extension activity trigger — there were periodic “something is
    happening!” callbacks causing the laptop to wake up.

    To fix it I pulled IOUSBFamily-327.4.0-log.dmg from the Apple
    developer site, since that bundle contains a fresh copy of the 10.5.6
    IOUSBFamily kernel extension as a means of backing out the debug-
    logging version that’s also shipped in that disk image.

    Once the IOUSBFamily extension had been overwritten, everything was
    fine again.[/quote]

    So it turns out that the instadmg process did not properly update that file, even though it properly ran the full 10.5.6 combo update. I would chalk it up to the disk from which it was built, more than the InstaDMG process itself.


    I was seeing strange things using OEM discs as well. Using instadmg with a retail cd + 10.5.6 has worked well on uni-body macbooks in our environment.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Comments are closed