Home Forums OS X Server and Client Discussion Open Directory Turn off background sync

This topic contains 4 replies, has 3 voices, and was last updated by  a4andrew 7 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #370698

    daniel.svensson
    Participant

    Hi!
    We have a have a golden triangle setup with PHD users who sync at login and logout. We dont want any background sync to take place since many users are on a wireless network resulting in a lot of incomplete syncs and so on.

    The problem we have is that the the background sync settings keeps reverting to the default settings e.g ~/ and automatic sync turned on.

    To avoid this we send out a MCX setting to all users to manage these settings but it seems that, especially for wireless users, the MCXd doesnt maintain that MCX after the cache expires so the client starts to sync in the background again…
    Sometimes it works to dirty the cache and trash the local com.apple.homeSync.plist file but the problem comes back after awhile.

    We have tried to use a launchd job that turns automatic sync off; “defaults write com.apple.homeSync periodicSyncOn 0”
    This runs every time a user logs in but mcxd doesnt seem to pick this up until a restart and even then the background sync kicks in from time to time…

    Another thing we’ve tried is to copy a “clean” com.apple.homeSync.plist with all the correct settings whenever a user logs in.
    This works in the sense that background syncs in off but since it writes a timestamp in this file when a sync occurs it will think that the nethome and localhome is out of sync.

    So, it all boils down to; How do I turn off backgound sync completely ?

    Best regards,
    Daniel

    #370720

    daniel.svensson
    Participant

    Maybe managed to solve this “problem”, fingers crossed 😉

    By changing the default sync-settings in /System/Library/CoreServices/mcxd/Contents/Resources/CinchDefaults.plist I think way have got what we wanted….

    I simply removed the dictonary and string “path ~” in the syncedFolder array in this file on our clients.
    Together with the above launchd job that sets the periodicSyncOn to 0 it does no longer start the background sync process even if the MCX cache expires.

    If you try to do a manual sync you will get the “There is nothing to sync” message which is want we wanted at this point.

    Br
    Daniel

    #370724

    daniel.svensson
    Participant

    Yes, I’ve thinking of that too but haven’t found a clear way to do that. Any tips on this ?!

    The setting you do in WGM at computer level that says “Update the pref cache every 17 days” only forces the clients to flush the cache no matter what after 17 days, its not a cache expiration setting. Or am I completely wrong on this !?

    The thing is that the clients are not away from the network more than a day or so. They are using network resources almost every day so I don’t think that is the problem.
    However all wireless clients login to the network using a 802.1x setting and it seems that MCXd have trouble updating the cache since there is no network available just then.

    I’ve doing some testing with this by dirtying the cache on a client while not connected to the network and as soon as I connect an ethernet cable it updates the cache directly after the network change is posted. Every time, rock solid.

    But when doing the same thing on a wireless network it updates sometimes and fails sometimes leaving the computer in an unmanaged state.

    Br,
    Daniel

    #381790

    a4andrew
    Participant

    I’ve experienced a similar sync problem where some of the old settings wouldn’t let go. I had to delete ~/Library/Prefs/com.apple.MCX.plist to resolve the issue (I also deleted ~/Library/Prefs/com.apple.HomeSync.plist for a clean slate.

    10.6.8, Golden Triangle Environment.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed