Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #354696


    Just finished bringing up my first OSX Server (10.2, not software updated… yet)
    Everytime I try to fire up Server Settings, it crashes (just the app. not the server).
    I’m not certain what could be wrong, and am such a newbie I’m not sure where to look.

    Only thing that leaps to mind it that it can’t do a reverse lookup for my hostname.
    Also when I was doing the server setup util. I gave the machine an unqualified hostname. Example foo, rather than .

    I know my unix, I know my OSX, but server… well it is all new now

    thanks in advance


    Ok, rebuilt server from blank HD.
    Now Server Setting will fire up, but how do I get it to connect? This seems like it should be obvious, but it isn’t.


    What happens when you enter the FQDN of the server in the connection dialog, then supply your Admin username and password?


    I get the same error no matter what I enter.

    All will return the error that Server Settings cannot find an agent on the port. Please check to make sure agent is running. (not exact wording, because I am not in front of server)

    things that are probably useful to know.
    I run my own DNS, but only own a portion of the IP range, so I don’t have reverse lookup control. There is reverse lookup, but it is DSL providers useless naming. something like .

    My DNS, is set up to provide with IP info or, but reverse is not set up. I will be moving the machine to internal private IP in the near future, and will have reverse DNS control at that point.

    Should I have an alias record for as for

    All IP’s and naming is examples (obviously, but wanted to be sure to be clear)

    I’ve seen at least one other posting with this issue, on another forum, but as yet neither of us have gotten useful feedback. I’m hopefull….

    Participant[email protected]@.3bbb3438/0

    This is the thread that helped me solve this issue.


    Thanks for the thread pointer. Were you experiencing the held-over serveradmind, or the non-starting serversettingsd?

    On our Server, serversettingsd [i:7c18117526]is[/i:7c18117526] daemonized:
    [code:1:7c18117526]root 378 373 373 2f4e198 0 S ?? 22:19.09 serversettingsd -x[/code:1:7c18117526](output from [b:7c18117526]ps ahjx[/b:7c18117526]) and I would expect the same to be the case with you.

    Out of curiosity, did you upgrade from 10.1.x to 10.2, or is your installation a fresh 10.2? Does your [b:7c18117526]/etc/watchdog.conf[/b:7c18117526] file contain the following line?[code:1:7c18117526]ssd:respawn:/usr/sbin/serversettingsd -x # Server Settings service[/code:1:7c18117526]


    I’ll try to answer your questions.

    Server Settings is daemonized on my server as well, but it does not appear to be in any startup script, at least not that I could find. So, currently if I want to run the Server Settings App. I have to start serversettings manually.

    This is a fresh installation of 10.2 Server. It is a wee bit hoopdy in that it is on an 8600 with a G3/300mhz upgrade card. (Using XpostFacto, from OWC). It feels like the Server Settings Daemon doesn’t install correctly, or at least doesn’t startup correctly.

    Lastly, that line is not in my watchdog script. I’m adding it, as it appears to be a useful place to ensure that this, and other daemons remain running.


    Sloppy, Lazy Apple. I’m wondering if other Sys Admin’s are running it this issue as well. Sounds like something that they should add to there Knowledge Base.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Comments are closed