Home Forums OS X Server and Client Discussion DNS Server Admin is not allowing me to configure DNS

This topic contains 2 replies, has 2 voices, and was last updated by  afp548contributor 9 years, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #378791

    Clinton
    Participant

    We have a Mac OS X 10.5.8 Server running DNS (and a few other services).

    When I connect to it (using Server Admin 10.5.3 [which comes from the Server Admin 10.5.7 tools]), and click to look at the DNS settings, all appears normal — it shows many reverse entries and two top-level domains. However, when I select one of our domains and open the disclosure triangle, the list is empty! [There should be over a dozen entries, and the reverse entries do show up.] If I then tell it I want to add, say, an A Record to the domain, almost everything disappears — and I am left with a list showing our two domains, one with a disclosure triangle underneath it showing a single entry, and one reverse entry to correspond to the new A record.

    `named` appears to be working fine. DNS names resolve. It appears to simply be that Server Admin is having problems with the data on the computer. No one here would have manually created a DNS entry.

    Now, while I think I’ve backed up the DNS (I backed up `/var/named/`, `/etc/named.conf`, and `/etc/dns/`, as mentioned [url=”http://serverfault.com/questions/87961/mac-osx-server-10-5-external-dns-questions/91906#91906″]here[/url]), I’m really not sure if just replacing the files would restore the DNS settings we have if things go south. I am contemplating going to settings and changing the log level from “Information” to “Debug”, but 1) I am just a little concerned that it might write a bad configuration to the disk, and 2) I think it would only affect `named` and not Server Admin, and, so far as I can tell, `named` is not having a problem. (Nothing looks strange in /Library/Logs/named.log when I open it via Console/Terminal. Oddly, though, when I click on the ‘log’ button for DNS in Server Admin, I see no text at all, just a fully white window. When I look at one of our secondary DNS servers, I am able to see the log file through Server Admin.)

    This entry appears in the system log when I run Server Admin on the server:
    [code]Jun 17 09:02:08 od1 Server Admin[3892]: Unexpected call to doMarkConfigurationAsDirty by ‘DNS’ plugin during updateConfigurationViewFromDescription[/code]
    It seems to occur after I’ve looked at DNS, look at another service, and then click back on DNS.

    Think that the most likely cause is a corrupt configuration file, I glanced through all the files that I backed up, and none of them is obviously gobbledygook.

    Here are some oddities I find when running Server Admin from a remote computer to manage the DNS.

    1. When I click to see the log file for DNS, the server starts writing messages like these to its system.log:
    [code]Jun 17 09:59:04 od1 kernel[0]: Limiting open port RST response from 252 to 250 packets per second
    Jun 17 09:59:06 od1 kernel[0]: Limiting open port RST response from 258 to 250 packets per second[/code]
    This stops when I click on a different service.

    2. The indeterminate progress indicator (the spinning wheel that appears beside the “Revert” and “Save” buttons in the bottom-right corner of Server Admin) looks really strange. As far as I can tell, instead of just spinning and waiting, it is being told to start spinning repeatedly, resulting in a jerky animation.

    3. Here are some of the messages being logged on the computer running Server Admin:

    At startup:
    [code]*** ERROR: -[GRAxes computeLayout]:1124 – plotRect height = 0.000000 <= 0.0 *** *** ERROR: -[GRChartView computeLayout]:1194 - Layout for overlay axes (0x18758f50) failed. ***[/code] (These messages don't concern me too much as they go away for a while if you delete ~/Library/Preferences/com.apple.ServerAdmin.plist). At shutdown: [code]2010-06-17 10:02:17.202 Server Admin[7770:10b] *** -[GroupTextField windowDidResignKey:]: unrecognized selector sent to instance 0x16e12490[/code] More concerning are these messages: [code]2010-06-17 09:59:47.269 Server Admin[7770:10b] Unexpected call to doMarkConfigurationAsDirty by 'DNS' plugin during updateConfigurationViewFromDescription Server Admin(7770,0xb0453000) malloc: *** error for object 0x1c115390: double free *** set a breakpoint in malloc_error_break to debug 2010-06-17 10:01:00.795 Server Admin[7770:10b] *** -[ServiceEntry sessionHost]: unrecognized selector sent to instance 0x2af500[/code] Any thoughts on: - what the problem is - how I can troubleshoot it - or how to fix it? If I do need to wipe out DNS and restart, is there a good way to do this?

    #378808

    Clinton
    Participant

    [url=”http://serverfault.com/questions/152173/server-admin-is-not-allowing-me-to-configure-dns/153256#153256″]I’ve solved the problem. [/url] It came down to a comment that Server Admin wrote to a file but would not read back from the file.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed