Home Forums Archive Exim Installer Nothing listening on port 25

This topic contains 2 replies, has 2 voices, and was last updated by  sambo 15 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #356688

    sambo
    Participant

    Hi all,

    I just installed Exim on my newish 12″ PowerBook, and it seems to start with no errors:

    [jerusalem:~] sambo% /usr/exim/bin/exim -bV
    Exim version 4.10 #1 built 6/-09/-2 21:40:39
    Copyright (c) University of Cambridge 2002

    However, there’s nothing running:

    [jerusalem:~] sambo% telnet localhost 25
    Trying ::1…
    telnet: connect to address ::1: Connection refused
    Trying 127.0.0.1…
    telnet: connect to address 127.0.0.1: Connection refused
    telnet: Unable to connect to remote host

    [jerusalem:~] sambo% ps -aux | grep exim
    sambo 943 0.0 0.0 1416 308 std S+ 1:25PM 0:00.00 grep exim

    Thoughts? Thanks!

    —sambo

    #356691

    sambo
    Participant

    Thanks for the reply.

    Yes, i see it’s not running.

    Odd thing, that config file. The installer wouldn’t write it until I made the directory o+w. Apparently the installer forgets to ask permission. I then fixed the config file ownership and it seemed OK. Before I did that, exim would die with the complaint that the config file was missing (as it was).

    anyway:

    [jerusalem:~] sambo% ls -l /usr/exim/
    total 48
    drwxr-xr-x 16 root wheel 544 Oct 25 18:53 bin
    -rw-r–r– 1 root wheel 23886 Oct 27 11:08 configure

    Yes, i made a few changes to the file. I added a hostname I would like to appear in the headers rather than the one the DHCP server gives me.

    primary_hostname = jerusalem.avoidant.org

    Also turned off host lookup, since the only thing I want exim to do in this case is send outgoing mail from my laptop to the world. No other users or uses.

    # host_lookup = *

    Aside from that, nothing.

    I used to run an older version of exim on my old powerbook, but at some point when I tried upgrading it stopped working. I was too busy to examine the causes, but now it’s become important, as I’m using other people’s networks for my major ‘net access, and it’s rather a pain to have to switch SMTP server settings 5 or 6 times a day. I’d prefer to just use “localhost”.

    Thanks!

    —sambo

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed