Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #354779

    I installed 10.2 Server on a G4 and using MySQL Manager I enabled MySQL. So last Friday I got an Xserve and was hoping it would be that easy – it wasn’t. I keep getting the following error

    Can’t connect to local MySQL server through socket ‘/tmp/mysql.sock’ (61)

    With 10.1.X Server I had the same problem. I think I used a fix I found on an article. I created a MySQL startup item and that seemed to work. However, what I tried in 10.1.X doesn’t seem to work in 10.2.

    Anyone know how to fix this?


    I finally got around to troubleshooting this so here is what I did

    I checked the .err file in /var/mysql

    021210 15:44:11 mysqld started
    021210 15:44:11 /usr/libexec/mysqld: Table ‘’ doesn’t exist
    021210 15:44:11 mysqld ended

    That error means that mysql_install_db wasn’t run even though I pressed the install button in MySQL Manager.

    So I ran mysql_install_db in Terminal and got an error. I had to use this

    mysql_install_db –force

    Now I check the eroor log and I get this even though host.frm exists

    021210 16:20:12 mysqld started
    021210 16:20:12 /usr/libexec/mysqld: Can’t find file: ‘./mysql/host.frm’ (errno: 13)
    021210 16:20:12 mysqld ended

    Problem is that the user “mysql” does not own the file “root” does. For all the files and the folder /var/mysq/mysql

    Owner: mysql
    Group: admin
    Permissions: 770 (rwxrwx—)

    Now I click the Start button in MySQL Manager and all is well

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Comments are closed