Home Forums Archive Exim Installer Fresh Install But not Workin [undefined reference to _crypt]

This topic contains 10 replies, has 2 voices, and was last updated by  w1r3d90d 16 years ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #356311

    w1r3d90d
    Participant

    After a fresh install of 10.2 Server, I used the Exim Installer to install everything.
    I’ve configured my configuration file.
    I verified that Exim is running but when I try to send mail it tells me that it refused a connection the port.

    [Server:~] w1r3d90d% sudo SystemStarter stop SMTP
    Password:
    Welcome to Macintosh.
    Exec failed for item /Library/StartupItems/Exim: Permission denied
    Sendmail mail server (650) did not complete successfully.
    Startup complete.
    Hangup
    [Server:~] w1r3d90d% sudo /usr/exim/bin/exim -bd -d
    dyld: /usr/exim/bin/exim Undefined symbols:
    /usr/exim/bin/exim undefined reference to _crypt expected to be defined in /usr/lib/libcrypto.0.9.dylib
    Trace/BPT trap
    [Server:~] w1r3d90d%

    #356316

    w1r3d90d
    Participant

    Ok, I guess I didn’t read further down the main page. It seems someone else had this same problem and solved it by copying over “libcrypto.0.9.dylib” and “libssl.0.9.dylib” from his OS X 10.2 iBook to his OS X Server 10.2.

    Joel made the suggestion that the guy messed with theose files….however I’ve found that the files installed from Server 10.2 are different from just plain 10.2.

    So anyone installing Exim Installer on Server 10.2 will most likely need to copy these file from a normal 10.2 mac.

    So that Problem has been solved……
    Now I’m trying to get Catchall Enabled on four different domains….

    This is what I have in my config file:

    virtual_domains:
    driver=aliasfile
    domains=LOCAL
    file=/usr/local/exim/virtual/${domain}/aliases
    search_type=lsearch

    And this is the error I’m getting:

    [Server:~] w1r3d90d% sudo /usr/exim/bin/exim -bd -d
    Password:
    Exim version 4.10 uid=0 gid=0 pid=544 L=834cd8 D=fff7577f
    probably Berkeley DB version 1.8x (native mode)
    changed uid/gid: forcing real = effective
    uid=0 gid=0
    auxiliary group list: 0
    LOG: PANIC DIE
    Exim configuration error in line 219:
    main option “virtual_domains” unknown
    search_tidyup called
    >>>>>>>>>>>>>>>>>> Exim pid=544 terminating with rc=1 >>>>>>>>>>>>>>>>>>

    Any advice?

    #356319

    w1r3d90d
    Participant

    ok, I was told by someone to move the virtual_domain settings to the router section of the config file. I did that now I’m getting this error:

    [Server:~] w1r3d90d% sudo /usr/exim/bin/exim -bd -d
    Exim version 4.10 uid=0 gid=0 pid=437 L=834cd8 D=fff7577f
    probably Berkeley DB version 1.8x (native mode)
    changed uid/gid: forcing real = effective
    uid=0 gid=0
    auxiliary group list: 0
    trusted user
    admin user
    LOG: PANIC DIE
    Exim configuration error in line 379:
    router virtual_domains: cannot find router driver “aliasfile”
    search_tidyup called
    >>>>>>>>>>>>>>>>>> Exim pid=437 terminating with rc=1 >>>>>>>>>>>>>>>>>>

    #356320

    w1r3d90d
    Participant

    alright, the same person who told me to put it under the router section also suggested the directors section so I did that too. I’m getting the same error with both setups.

    [Server:~] w1r3d90d% sudo /usr/exim/bin/exim -bd -d
    Exim version 4.10 uid=0 gid=0 pid=464 L=834cd8 D=fff7577f
    probably Berkeley DB version 1.8x (native mode)
    changed uid/gid: forcing real = effective
    uid=0 gid=0
    auxiliary group list: 0
    trusted user
    admin user
    LOG: PANIC DIE
    Exim configuration error in line 480:
    transport virtual_domains: cannot find transport driver “aliasfile”
    search_tidyup called
    >>>>>>>>>>>>>>>>>> Exim pid=464 terminating with rc=1 >>>>>>>>>>>>>>>>>>

    #356327

    w1r3d90d
    Participant

    Does it matter what the file name is for that flat file and will an entry like this work:

    *: w1r3d90d

    -Brian

    #356329

    w1r3d90d
    Participant

    Oh yeah, duh. The flat file name would be the domain name.
    I’m assuming that I can use the above entry to enable a catchall.

    #356331

    w1r3d90d
    Participant

    I have four domains that are all have different owners. What I need is a catchall for domain1 to go to user1, a catchall for domain2 to go to user2, etc.

    I was going to have a file for each domain that had “*: user1” in it, pointing to the user that receives all the mail for that domain.

    I’m also going to need a way of blocking certain virtual addresses.
    Like if [email protected] is sold to a spammer I can block it without blocking the rest of the mail going to that domain.

    Does this make sence?, because I’m starting to confuse myself I think. heh

    -Brian

    #356333

    w1r3d90d
    Participant

    Ouch.

    Is that really required? what exactly does dsearch do?
    All users will be local users so why do I need “* : [email protected]” ? Wouldn’t “* : someone” work?

    I really don’t have enough time to compile exim from source and work out all the bugs and the configuration. I might have to find a quick fix while try to get exim to do what I need.

    Nothing is ever as simple as it should be.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Comments are closed