Home Forums OS X Server and Client Discussion Updates 10.4.11 on Core 2 Duo wrecks PowerPoint

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #370712
    knowmad
    Participant

    this popped up in a seemingly random smatter until I noted specific chips.
    Issue: under 10.4.11 powerpoint works fine to open/create/edit/save/print slides but cannot view them in slideshow mode. In fact anything having to do with the slideshow, such as fades, causes the screen to go black and powerpoint to crash.
    At first I connected it to 10.4.11 only, then I realized it was 10.4.11 combined with intel macs and finally I noticed it only happened on core 2 duo chips.
    The report it send to apple says it is a kernel access violation.
    I have tried everything I can think of from the office side of things to no avail:
    removing prefs, re-running first run, ripping the program out with all files removed and then
    reinstalling
    re-updating (with a test between each update)
    running as a different user
    running as root
    and for the heck of it running applejack.
    If anyone comes across a fix, I would love to know it, in the mean time avoid this update (a little late for a notice) if you need powerpoint to do slideshows on a core 2 duo machine.

    #370713
    knowmad
    Participant

    chip connection got blown just now, seems to happen on some Core 2 Duos and some Mac Pros (Xeons) but not others…. no common thread yet….

    #370763
    homepup
    Participant

    We are experiencing this at our location as well, however, not all MB C2D seem to be affected, but those are the only hardware types that we’ve seen exhibit the behavior.

    There are several discussions about a possible fix, but so far, none have worked for us. We have also filled out an Apple Bug Report on this.

    #370767
    knowmad
    Participant

    a co-worker came up with this, so far it has fixed the issue:

    (can use root instead of single user mode if you feel like it)

    Step one: Copy OpenGL.framework from /System/Library/Frameworks on a known working machine to a USB stick, or something similar. Rename the copy to OpenGL.framework.old.

    Step two: Copy OpenGL.framework.old to your broken MacBook.

    Step three: Reboot in Single User mode.

    Step four: /sbin/mount -wu / to get write access to the root volume.

    Step five: cd to /System/Library/Frameworks

    Step six: mv OpenGL.framework to OpenGL.framework.bak

    Step seven: mv OpenGL.framework.new to OpenGL.framework

    #373389
    donander
    Participant

    knowmad:

    In the procedure you say “Step one: ….Rename the copy to OpenGL.framework.old.” but then you say “Step seven: mv OpenGL.framework.new to OpenGL.framework”, which doesn’t make sense. Do you mean to say “Step one: ….Rename the copy to OpenGL.framework.new”?

    #373390
    knowmad
    Participant

    wow, that went MONTHS without being caught.
    yes, you are correct, I meant new.

    Before you do this, you need to know a few things.
    in 10.4.11, while this fix does fix some of the wierd behavior, it screws up others and makes more issues than it is worth.
    I found that the best thing to do was either keep a second image just for those laptops (they had special chipset in general) OR go to 10.5
    nothing else really seemed to fix things long run.
    sorry

    #373391
    donander
    Participant

    knowmad,

    Thanks for your quick reply. I want to make sure I am clear on this. Are you saying that if I upgrade that machine to Leopard it will fix this issue? I was going to do that anyway before this came up so that looks like the best option for me.

    Thanks,
    donander

    #373392
    knowmad
    Participant

    wait, no, not exactly.
    if you UPGRADE you will create a situation that allows the issue to persist.
    If instead you archive and install or image you machine, install a fresh OS 10.5 and then migrate your account, the issue will go away.
    In truth I have never run an ‘upgrade’ from 10.4 to 10.5 so I don’t have that issue as a first hand experience, but it has been reported in other places.

    but yes, if you install 10.5, the issue goes away.
    Best way I know of to do it, make an image of your current machine, put it some place safe. Wipe the drive, install OSX.5, create a throw away user on the machine, mount the image of the old machine, run the migration utility, log in as yourself and dump the throw away user.
    OR
    install OSX 10.5 and start using it from scratch.
    either which way, it works.

    #373394
    donander
    Participant

    Sorry, I was using “upgrade” as a generic term. My bad. I typically do an Archive & Install. Do you think that would be ok or do you think the wipe/install/migrate process is necessary?

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Comments are closed